No name

Links

Software
OtherSoft
Images
Mikrotik RouterOS log/backup to email

Mikrotik RouterOS log/backup to email


visibility96 2022-05-02 10:38:30
Задача: сформировать и отправить на email ежедневную сводку и копию насроек роутера Microtik

На хабре есть статья, где приводится подобный скрипт, но из-за того что он устарел, по синтаксису, предлагаю свой, немного исправленный вариант данного скрипта. Ссылка на оригинал ниже.

:global backupfile ([/system identity get name] . ".backup") 
:if ([/file find name=$backupfile] != "") do={/file rem $backupfile}
:delay 2s

:global logMessages;

:set logMessages "";

:foreach i in=[/log find ] do={

:set logMessages ($logMessages . [/log get $i time ] . " ");

:set logMessages ($logMessages . [/log get $i message ]);

:set logMessages ($logMessages . "\n")
;}

/system backup save name=$backupfile password=O05+:BK~Pg3U6aS
:delay 5s
/tool e-mail send to="[email protected]" subject=([/system identity get name]." daily log&backup") file=$backupfile body=("Router's backup file " . [/system identity get name] . ". \nCompleted: " . [/system clock get time] . " " . \ [/system clock get date] . " \n____________________\n \nUptime: " . [/system resource get uptime] . "\nFree RAM: " . [/system resource get free-memory] . " of " . [/system resource get total-memory] . " kbytes. \nFree space: " . [/system resource get free-hdd-space] . " of " . [/system resource get total-hdd-space] . " kbytes. \nBad-blocks: " . [/system resource get bad-blocks] . " %. \nCurrent CPU load: " . [/system resource get cpu-load] . " % \n____________________\n \nLast events in log file: \n \n" . $logMessages . " \n____________________ \n" . [/system identity get name])

Источники:
1) Оригинал скрипта:

https://habr.com/ru/post/153971/

Back